Can not reset /opt/gitlab/embedded/etc/gitconfig

After attempting to set some configurations in /opt/gitlab/embedded/etc/gitconfig via /etc/gitlab/gitlab.rb and running gitlab-ctl reconfigure I can not get /opt/gitlab/embedded/etc/gitconfig back to a default(working state).
As it stands not I can not create any new projects as a result.
Removing or commenting out the line, or attempts made removed will not fix /opt/gitlab/embedded/etc/gitconfig:

omnibus_gitconfig['system'] = { "receive" => ["fsckObjects = true"] }

Stopping gitlab, and deleting /opt/gitlab/embedded/etc/gitconfig, and running gitlab-ctl reconfigure will not re-initialize the file, it is pulled a cached copy from somewhere instead of re-creating. Will follow-up to create a bug report, but would like to fix my gitlab CE installation first.

Would like to add that I updated to 7.10 today, but do not think that has anything to do with the root of the issue.

Do not know if this was the best way to rescue, but it seems that it worked.
I made a back up of /opt/gitlab/embedded/nodes/{hostname}.json then went in and edited the section for omnibus-gitconfig

Then ran gitlab-ctl reconfigure, and that seemed to get me back to a working configuration.

I have a similar problem, but in a different file, so I am also interested in finding out how to reset a configuration file after making unsuccessful changes via /etc/gitlab/gitlab.rb and running gitlab-ctl reconfigure.

I am no expert at all, but I solved my problem by editing the following file which appears to be a cache, or file that is built as a result of things set in gitlab.rb. I backed up, and edited the file as needed for the section in question. I guess the only tricky part is knowing which section is built by what you set in gitlab.rb, and not screwing up the json syntax.

This should be solved with the latest 7.10.1

Yes, was fixed. Verified this morning.