Can't create new projects

I have been having issues with my gitlab instance after updating the SSL certificates which had expired and running a gitlab-ctl reconfigure. We noticed after this that GitLab had dropped about 3 weeks worth of the most recent commits (apart from one which was done 9pm the evening before), they just disappeared from the UI. When I tried to re-create those repos we got an error that they already existed on file. Unfortunately I did not have a recent backup so could not restore those missing repos. We were able to create a few new repositories using different names and then a couple days ago that all stopped working, we now get the following error no matter what repo name we use:

The form contains the following errors:

  • There is already a repository with that name on disk
  • uncaught throw :abort

I have tried creating a new GitLab instance and restoring a current backup from the old instance. The restore completed but when I try creating a new repository now I’m getting an error with no details, it’s just blank:

The form contains the following error:

Here are the relevant log entries:

==> gitlab-rails/application.log <==
2021-03-30T13:59:58.652Z: Unable to save project. Error:

Does anyone have any advice to debugging this issue?

Thank you