CI/CD no CMAKE_Fortran_COMPILER could be found

Hi everyone,
First of all, I m using my pc as a Gitlab-Runner.
the problem is that when I run the same command line using git bash it works but when I send the command line using the .gitlab-ci.yml I get an error :confused: one finds the Fortran location but the other does not.I searched everywhere on the internet and found nothing.




thanks for help

Hi there,

I guess there is some env. var. missed by the runner shell executor? Add a env call to the build script and compare the variables with the variable in your git-bash. Are they running as the same user?

Good luck!

1 Like

thanks for replying. Yes, its the same user and about the env call :

gitlab ci:

I tried many ways, I don’t know how to show the environment variables.

and thank you so much for the help

OK this makes all a bit more clear…

Your runner is using powershell not the git-bash. May be some of your env. var. available in git-bash are define somewere else than in the system env. setting?

Replace the env command by this command: Get-ChildItem env: this will give you all what is set and you can compare it.

1 Like

thank you again but the get-childitem env and the local shell show the same env. :confused:

Have you tried running the same commands from your YAML inside a powershell instead of bash-shell?

1 Like