CI job doesn't triggered for tag


My problem is the following.
I had a 12.6.7-ee (or 12.7.6 i can’t remember) version in a self hosted way. I have a yaml with this:

       stage: .post
             - tags
            - mvn clean
            - mvn $MAVEN_CLI_OPTS -Dmaven.test.skip=true package
            - ls -la
            - ./ $CI_COMMIT_TAG $CI_PROJECT_ID "myStuff" "myProject"

This triggered, if i created a tag and this made me a release via Gitlab Api. Thats worked fine.

Between September 26-28 i updated to 12.9.2-ee (0ad76f4d374) version. Around that i noticed, that projects without any “tag” related CI command reran their whole commit job on tag creation. But this code above didn’t triggered as before.

I also tried to replace only:tags section with this:

        - if: $CI_COMMIT_TAG != null
          when: on_success

But this didn’t helped at all.

Can i ask for some help, what is going on here?


Not entirely sure in your case, but I can say that I suffered a great amount of confusion over the fact that git tags and gitlab CI/CD runner tags are distinctly unique and totally unrelated entities despite their unfortunately identical terms. For example, $CI_COMMIT_TAG does not refer to git tags but rather CI tags within the gitlab runner ecosystem.