CI pipeline stuck with self hosted runner

Hi, I need some assistance with an issue I have been facing since couple of days.
we are running our CI CD pipelines on shared runners and it works fine. When I am adding self hosted runner (GCP instance), everything seems fine, except when I run the pipeline, it get stuck forever with the message " This job has not started yet. This job is in pending state and is waiting to be picked by a runner"
In the logs, I am seeing error - Checking for jobs… failed couldn’t execute POST
against Post dial tcp connect: permission denied.

I have tried with open firewall also, but still getting same error.
Tried with both project specific runner or Group runner, same error.
With Docker, Docker+machine or Shell executor, same error.

I have installed gitlab-runner, docker with root and also registering with root user.

sudo gitlab-runner register
–url “
–registration-token “”
–executor “docker”
–docker-image alpine:latest
–description “docker-runner”


Any direction would be appreciated. Thanks in advance.