Cloned self-managed gitlab ce not working - timeout

Server not working

My new Gitlab CE self-managed server is not working, whenever I put its public ip address on my browser to access it, I get " The connection has timed out" on the browser.

Can someone help me get this sorted? I had to pause further commits to the current server until I get this timeout fixed and fully moved onto the new server.

How I made this server

This was done by making an aws image of the current server (which works fine using the DNS and using the ip).

From the image I started a new aws instance with the same config and hardware as the existing server. Then I SSH into it, upgraded from Ubuntu 18.04 LTS to 20.04 and then to 22.04 LTS.

Then I changed the /etc/gitlab/gitlab.rb to point to the ip of the new server, such that I get external_url ‘http://(public ip)’.

I then ran sudo gitlab-ctl reconfigure and sudo gitlab-ctl restart. I also tried rebooting the instance. Nothing worked, I just get timeout on the browser.


AWS instance t2.large


  • Self-managed
  • GitLab 16.9.2-ce.0
  • Ubuntu 22.04 LTS

I expect the problem here is because the version of Gitlab you have on the server is for Ubuntu 18.04. And you have upgraded to Ubuntu 22.04. What you should have done was upgrade Gitlab to the latest version possible on 18.04. Then upgrade to 20.04. Then upgrade Gitlab again to the latest available on 20.04. Then upgrade to 22.04. Then if necessary upgrade to the latest Gitlab on 22.04.

Each Gitlab upgrade requires waiting until the background migrations have finished, before starting the next upgrade on the upgrade path. See Gitlab upgrade docs for more info: Upgrade GitLab | GitLab

I did upgrade Gitlab to the latest version possible on 18.04 before upgrading Ubuntu to 20.04. Forgot to mention that.

I eventually found the issue, my new aws server didn’t have ports 443 and 80 set under “Inbound rules” in security group, and hence was blocking any traffic trying to access it.

Now it opens up the login page, but I’m stuck with yet another issue of “Invalid login or password.”, I might open a new post for that.