Connection refused when trying to clone/pull/push from repo on


Since yesterday October 28th I am unable to connect to my company repositories on

We use a dockerized Theia IDE with git installed and I use a credential.helper to log onto gitlab: i.e. I have a .gitconfig file in my root of the kind:

	name = <my-gitlab-user>
	email = <my-user-email>
	helper = store

and a git-credentials file of the kind:


Until 2 days ago I was able to clone/pull/push without issues, but since yesterday for such operations I get an error of the kind:

 → git pull
fatal: unable to access '': Failed to connect to port 443: Connection refused

The curios thing is that since my whole dev team uses the same container I use for my IDE, one would expect that we all have issues with. Instead, the issue seems to impact only some of us: i.e. for the same repo with the same dockerized IDE, some of us can pull/push without problems and others like me cannot do anything with the remote repo (i.e. every pull/push/fetch results in the above error). Yes, I am not the only one with the issue, but there are people without issues.

The other worrying thing is that I have the same issues also on my Windows machine and on my personal Mac laptop. Just for an experiment, I created a Debian container for scratch, installed git and tried to clone a public repo from GitLab: baaam, same issue, but after few tries the clone worked, after few others did not.

My git version on my container IDE is:

 → git --version
git version 2.11.0
1 Like

I have the same issue!