Could not read from remote repository from GitLab.com


#1

Hi all, apologies in advance, this is my first post!

I’ve been collaborating on a private project hosted on GitLab.com for the last year or so and everything’s been seamless thanks!

Recently, broke up for Easter break - last Thursday. Have switched my machine back on today, and cannot git pull/push/clone or do anything with this repository.

My ssh credentials are still good. I can clone/push/pull a number of other GitLab hosted projects. I’m just now running out of ideas! Even if I try and clone the project into a fresh directory I still get the same error which is:-

fatal: '/var/opt/gitlab/git-data-file04/repositories/gooii/{repo-name}}.git' does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights and the repository exists.

A work colleague has checked this repo and can still pull/push/clone etc which is leading me to believe some weird permissions change has occurred but I have no idea how!

My other concern is that it’s reading from /var/opt/gitlab… a folder which doesn’t exists on my local file system.

Does anyone have any suggestions as to how I might be able to resolve this issue?

Many thanks!

Ben


Could not read from remote repository after update to gitlab 10.0.3
#2

I have exactly the same problem. On Friday 14.4. I worked on my repo from a remote machine via ssh and I was able to push/pull fine. Today I tried to push/pull and got the same error.

The problem is with this repository: https://gitlab.com/fft-on-tta/fft-in-tce
I worked on an other repository that day from the remote machine and it works fine: https://gitlab.com/fft-on-tta/share
I use SSH authentication for both.

I fixed it by switching my fft-in-tce repository to HTTPS authentication.

Cheers,
Jakub


#3

Thanks Jakub. I’ll give that a go!

Initially didn’t try it as all my other GitLab hosted projects appear to be fine over ssh.

If I do ssh git@gitlab.com -T I get the usual welcome message and my username so they know who I am :slight_smile:

If it means I can get on with my work then that’s good at least!

Cheers

Benj


#4

Yep. Switching to https works. Switching back to ssh, the same error reappears. Although I can use ssh for all my other GitLab hosted repos, so not sure what’s happening here? :frowning:


#5

I’m having the same issue. https isn’t an option for me as we use ssh keys to auto-checkout the code and with https we’re prompted for a password.

I’ve tried git pull from other checkouts of that same repo, and checking it back out from other machines that have their keys on this project. Nothing works.

Odd that it suddenly doesn’t work.

I’d imagine this is becoming a systematic problem and they’ll have other complaints.


#6

I have same issue like that.

I’m manager about 80 repository and some repo work with ssh (clone/pull/push) and some not.

I think because they upgrade server yesterday and break something :frowning:


#7

I have the same issue. A workaround is switching to HTTPS. However, I think this should be fixed on GL side.


#8

Facing the same issue as well. HTTPS works.


#9

Wow! Thanks for the responses people. I didn’t realise this was such an issue and was me missing something. I guess we could really do with escalating this, as working via https is not really an option for me either. Any where else I can shout about this problem :slight_smile:


#10

Even if you have a free account, you can create a support ticket:

https://support.gitlab.com/hc/en-us/requests/new

This helps in several ways:

  1. They will fix your repos.
  2. They realize this is a larger problem and will dedicate someone to fixing this issue as a whole instead of (a) ignoring it or (b) fixing repos one at a time.

#11

BTW, looks like it’s been fixed for my account. ssh is now working again.

I did nothing but (a) comment here, (b) submit a ticket, and © answer their first “systems greetings” message they send when you join this forum.


#12

Thanks for the heads up Richard! It’s also working for me now :slight_smile:


#13

Yep, seems to work now.


#14

Hi, almost a month later of this post and I stumbled upon the very same issue, any new ideas to fix it?

Thanks


#15

It was already fixed by the GItlab team :slight_smile:, just report it to them.


#16

Facing the same issue as well. HTTPS works.

UPDATE: after I reset my modem. It works well.
I think it is network issue.