Deploy new snapshot version to package registry with maven

I have setup a gitlab ci job which deploys my artifact to the project’s package registry via maven. I’m using a snapshot version, using access tokens and so on – everything is working fine. However when I run the job again, the new version of the snapshot (same version number but different timestamp) is not deployed.

So, this is my package registry:

0.0.1-SNAPSHOT published by ... Maven

with the following files:

When I run the deploy job (maven deploy -s ci_settings.xml) again, I get the following output:

[INFO] --- maven-install-plugin:2.4:install (default-install) @ my.project ---
[INFO] Installing /builds/ to /builds/
[INFO] Installing /builds/ to /builds/
[INFO] --- maven-deploy-plugin:2.7:deploy (default-deploy) @ my.project ---
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  3.679 s
[INFO] Finished at: 2020-11-27T11:41:23Z
[INFO] ------------------------------------------------------------------------

However nothing is installed. It is the very same output I get when I deploy the artefact for the first time (when it is working).

Is it possible to deploy different snapshot artefacts in the package registry which only differ by the timestamp? What do I need to do for that?

If this is not possible: How can I replace (i.e. update with the same version but new timestamp) the artefact? Is it possible to remove an artefact from the registry (i.e. not manually via the web interface but in the script)?

Strange… it has started to work now. I’m still wondering why it did not work before since I did no change anything in the ci scripts.

The new artifacts are now correctly deployed the one existing package. That is, the one entry has now several artifacts with different timestamps.

Anyway, is there a way to delete packages from the package registry via CI scripts?