Docker registry broke after Group URL change

Problem to solve

I have a group with two projects in it. I use personal access token to push docker images to the projects in the group, and I use deploy tokens to pull the images on the server for deploys.

Everything was working fine until I changed the group URL. When I tried changing the group URL, I got an error message saying that the group URL could not be changed due to the existing container registry images. I went ahead and deleted all images from both projects and then changes the group URL successfully.

After changing URL, I cannot push images to the container registry anymore. Push to either of the projects fails with error server message: insufficient_scope: authorization failed. I recreated my personal access token and logged into gitlab registry again in docker. Still not working. I can push to other projects that are outside of this group, but the two projects in the group cannot be pushed to anymore.

Steps to reproduce

  1. Push images to project inside the group
  2. Delete Images from project’s container registry
  3. Change group URL to something else
  4. Push to the same project with new group URL from docker
  5. Observe server message: insufficient_scope: authorization failed error from docker

Versions

  • Self-managed
  • GitLab.com SaaS
  • Self-hosted Runners