Dotnet pipeline throws a "unsupported compression method" error never seen before

Hi there,

This is my first post, so forgive me if something escapes me.

I’m constantly getting the same error whenever I run a pipeline for any of my dotnet projects.

$ dotnet restore ${Solution}

  Determining projects to restore...
/usr/share/dotnet/sdk/3.1.300/NuGet.targets(128,5): error : The archive entry was compressed using an unsupported compression method. [/home/gitlab-runner/builds/36EyP1yn/0/actio/web/backend/common/mapper/Jalasoft.Actio.ObjectMapper.sln]
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit status 1

Everything was working perfectly yesterday. The runner was installed on a virtualized ubuntu and running the pipelines normally.

Only thing that was made differently is the migration from environment that I did. I created a VDI and copied it to another host where I configured the new virtual ubuntu, updated the network configuration and successfully registered the runner.

Then I proceed to run the pipeline and the error appeared.

There are 2 things that bug me:

  1. It seems like the error is not throwed by dotnet. It doesn’t have a code nor it
    happens to me if I run it manually.

  2. All the environment settings used to work. The runner is inside a copy of an ubuntu image (virtualized VDI). The original image was running perfectly and never had this problem (now it’s turned off to avoid clashes).

This migration is the only thing that could have been the cause for this issue. As I already stated, the original image was running great.

Any help would be greatly appreciated.

I just ran into a similar problem, what worked for me was running dotnet restore --force --no-cache