Enabling GitLab Container Registry


I want to enable the Container Registry. I’m working on a GitLab server that was initially set up by somebody else. I think it’s an omnibus installation, based on the presence of an /etc/gitlab/gitlab.rb file. I can’t see that registry is currently running, at least I can’t see anything listening on port 5000.

I tried to follow the instructions here:

Do I just add the settings in the gitlab.rb file and reconfigure? I can’t see any registry settings at all in the existing gitlab.rb file.

Am I right in thinking that the registry is a docker container? If so, presumably I need to have docker installed?

Yes, the registry is a docker container and docker must be installed. You can check this with docker ps and the output should look something like that if the registry is running.

# docker ps
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                        NAMES
089ce0c6dcb1        registry:2          "/entrypoint.sh /etc…"   11 days ago         Up 11 days>5000/tcp   registry

After you have install the container registry should it appear in the menu. I have tried the about and tried updating the gitlab.rb without success. does the entire services need to be restart after you run gitlab-ctl reconfigure?

No, I guess best is if you imagine this as two separate systems. You need a GitLab and a separate container registry running.

You need to configure the registry to use the GitLab as a authenticator and after that you can enable the registry for users for certain projects in the GitLab.

Hi There
I have installed the latest helm chart for gitlab and I included the registry. However my CI/cd pipelines are failing when they try to connect to the registry. my problem is the registry doesnt seem to be enabled in the gitlab gui - there seems to be no option to add the registry via settings in gitlab to a project or at an over all setting. The documentation does indicate that you need to enable the registry post install. I saw something in the omnibus docs about gitlab.yml - but I see no config map matching that file where it might be enabled. Registry pod and secrets look good to me but any idea how to see the registry in the gitlab gui?

Thanks Paul