Error 404 Installing Gitlab CE

Hello all,

i’m trying to install Gitlab CE on a Oracle Linux.

I’m following the Download and install GitLab | GitLab guide

but every time i try to do step 2:

  1. Add the GitLab package repository and install the package
    Add the GitLab package repository.
    curl -sS | sudo bash

I’m getting error 404 Not found has you can see below:

curl -s | sudo bash
Detected operating system as ol/8.
Checking for curl...
Detected curl...
Downloading repository file: 
curl: (22) The requested URL returned error: 404 Not Found

Unable to download repo config from: 

This usually happens if your operating system is not supported by, or this script's OS detection failed.

You can override the OS detection by setting os= and dist= prior to running this script.
You can find a list of supported OSes and distributions on our website:

For example, to force CentOS 6: os=el dist=6 ./

If you are running a supported OS, please email and report this.

I already tried tried to override OS but still same error.

Any ideas on what i may be doing wrong? and possible solucions

I suggest you use a supported Operating System instead of attempting to install on an unsupported system.

In Requirements | GitLab on the supported OS list ORL is listed has supported.

However, as you can see from your errors above it isn’t working. You would be better utilising CentOS/RHEL or Debian/Ubuntu as they simply just work without having to override the versions.

Searching here you have a couple of options:

  1. Download the rpm directly and install it.
  2. Attempt the override again but use ol/7 instead of el/6 or el/7. Will be a bit hit-and-miss, but to be honest, you will get far much more help and assistance using a natively supported distro, than one that requires a hack to install it.
1 Like

Tk you for reply i will use some other OS then

Hi, it’s been a while since you posted this, but I came across it while assisting another GitLab user so I wanted to share this issue in case another comes across it later. GitLab does support Oracle Linux per our documentation but the vendor we use for our packages seems to not have Oracle Linux 8 as an option yet. I’ve written up an issue you can subscribe to for updates if you wish!

You can certainly try using the override as a workaround for now as well, or installing on CentOS or Ubuntu or another supported system if that’s an acceptable solution for you.