Problem installing latest version on Ubuntu 20.04

I have a fresh install of Ubuntu 20.04.

I am trying to install the ce version following the instructions on this site. I get to where I need to run this script and it fails.
curl -s https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh

The output from the above script is
Checking for curl…
Detected curl…
Checking for gpg…
Detected gpg…
Running apt-get update… done.
Installing apt-transport-https… done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ce.list…curl: (7) Failed to connect to packages.gitlab.com port 443: Connection timed out

Unable to run:
curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/config_file.list?os=Ubuntu&dist=focal&source=script

Double check your curl installation and try again.

I have tried to run the file https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/config_file.list?os=Ubuntu&dist=focal&source=script and what comes back is a webpage containing a “file not found” error.

How do I get past this particular step? Are the files that I need to place in /etc/apt/sources.list.d/ available somewhere for download directly?

Cheers,
Chris.

Ok. So I’ve managed to get the script to work. sudo -E ./script.sh did the trick.

1 Like

If you did as per installation documentation here: https://about.gitlab.com/install/#ubuntu?version=ce

curl -sS https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash

the difference here being the | sudo bash on the end compared to your command, it would have worked no problem. Anyway, you found a different workaround, but end result was the same :slight_smile:

1 Like

Hi iwalker,

I’d tried that first but it didn’t work. The issue was the environment, I need a proxy to be able to download from the web, so that’s why the sudo -E worked.

I suspect if I’d tried curl xxxxxxx | sudo -E bash it would have worked also.

Cheers,
Chris.

I was facing the same issue. It’s fixed now. Thanks support!

Yep, that would work, preserving the environment variables with sudo -E means that your proxy variable (export http_proxy) was preserved and carried across for use in the sudo session. The other alternative is set the proxy system-wide, then it wouldn’t matter as all users would by default have the proxy variable set. In that scenario, the -E would not be needed.