Error 500 after changing to https

I’m running 8.14.0 and I was trying to change my web services from http to https using the url , but after I set it up, all i get is “500 - Something went wrong on our end” for a webpage. I then decided to just put it back to http as i don’t have time to work the issue, but no matter what i do, i still get the same error. My high level steps:

vi /etc/gitlab/gitlab.rb and make my edits (url and redirect only)
I created a self-signed cert and put it in /etc/gitlab/ssl with the correct permissions and syntax
gitlab-ctl reconfigure
gitlab-ctl restart - just for good measure

At this point i just want to put back my http connection. Any help is appreciated. Thanks in advance.

If I run gitlab-ctl tail and then try to go to the gitlab http:// url, i get the following output in the logs:

==> /var/log/gitlab/gitlab-rails/production.log <==
Started GET “/foo” for at 2016-11-23 09:45:09 -0800
Processing by ApplicationController#not_found as HTML
Parameters: {“unmatched_route”=>“foo”}
Completed 401 Unauthorized in 15ms (ActiveRecord: 2.2ms)

Redis::CommandError (ERR invalid expire time in setex):
redis (3.2.2) lib/redis/client.rb:114:in call' redis (3.2.2) lib/redis.rb:729:in block in setex’
redis (3.2.2) lib/redis.rb:57:in block in synchronize' /opt/gitlab/embedded/lib/ruby/2.3.0/monitor.rb:214:in mon_synchronize’
redis (3.2.2) lib/redis.rb:57:in synchronize' redis (3.2.2) lib/redis.rb:728:in setex’
redis-store (1.2.0) lib/redis/store/interface.rb:17:in `setex’

@angry_garden_salad were you able to get a solution to the problem? I have run into the same issue.