Error 500 on one project

Problem to solve

Hello, we upgraded GitLab from 14.6.1 to 16.7.3 and all was fine yesterday. But this morning when we tried to access one of our project (only this one) the web interface returns code 500 error. It seems like everywhere we could see the project or try to access it, we would get the code 500 error. But we can still pull/push/clone in the project without problem. Only the display on the web page seems to fail.

Steps to reproduce

I ran a gitlach:check and I have this “error” :

Git user has default SSH configuration? … no
Try fixing it:
mkdir ~/gitlab-check-backup-1710337580
sudo mv /var/opt/gitlab/.ssh/config ~/gitlab-check-backup-1710337580
sudo mv /var/opt/gitlab/.ssh/id_ed25519 ~/gitlab-check-backup-1710337580
sudo mv /var/opt/gitlab/.ssh/ ~/gitlab-check-backup-1710337580
For more information see:
Please fix the error above and rerun the checks.

The gitlab-rake db:migrate returns this :

main: == [advisory_lock_connection] object_id: 128460, pg_backend_pid: 32093
main: == [advisory_lock_connection] object_id: 128460, pg_backend_pid: 32093

We also tried to put the old gitlab-secrets.json file since we saw some differences between the two but it didn’t work.

Any ideas or checks that I can run to find a solution ?

Thank you.