Error occured fetching folder content on Project Overview -> Details

Describe your question in as much detail as possible:
When visiting the Project Overview - > Details page for any of my repositories I see an error at the top of the page I see “An error occurred while fetching folder content”

  • What are you seeing, and how does it differ from what you expect to see?
    The application used to show the project details at this page and not have an error. I updated gitlab about a month ago which started this issue, since then I’ve updated it multiple times as new versions came out thinking this might be fixed. I read on some other forums it was an upcoming fix. I’m running the latest version and I’m still having this issue.

  • Consider including screenshots, error messages, and/or other helpful visuals
    Here is a screenshot of the said issue.

  • What version are you on (Hint: /help) ? and are you using self-managed or gitlab.com?
    Verisions:
    GitLab 12.9.2 (ac5568eb5d8)
    GitLab Shell 12.0.0
    GitLab Workhorse v8.25.1
    GitLab API v4
    Ruby 2.6.5p114
    Rails 6.0.2
    PostgreSQL 10.12
    Gitaly Servers

I run the latest docker image from here:
image: ‘gitlab/gitlab-ce:latest’

  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?
    I have tried disabling Rugged by executing:
    bundle exec gitlab-rake gitlab:features:disable_rugged
    as suggested by Stan Hu here: https://gitlab.com/gitlab-org/gitlab/issues/36864

I am fully available to submit more logs or information if needed. I just need some pointers on what would help diagnose this issue. Thanks!

Should I submit this as a bug?

Resolved: Nginx mod security update broke this - Here are my current ignores:

        modsecurity_rules '
          SecRuleRemoveById 920440
          SecRuleRemoveById 951240
          SecRuleRemoveById 932115
          SecRuleRemoveById 949110
        ';