An error occurred while fetching folder content

I can log into gitlab.com using a browser - no issues. I can view the list of projects. But when I click on a project to view it, the error appears “An error occurred while fetching folder content.” and I can’t view any files.

I can create a new project, but then when I go to view it as described above, I get the same error.

I don’t believe that I’ve made any changes that would affect this (eg proxy, web connection, etc).

UPDATE: Different browsers on different machines give the same result - files in a project cannot be viewed.

1 Like

I am having the exact same problem. Tried different browsers and all easy solutions as above.

I’m having this issue as well. I had it a few weeks ago and it seemed to just eventually resolve itself. I think it’s an issue Gitlab is having with their service.

1 Like

Interestingly, the ‘search’ function at the top of the gitlab banner works to get to a certain piece of code… but not to a certain branch.

Hey @ngeorgas, @the_aia, and @bakerc, welcome to the GitLab Community Forum! :tada:

We believe this might be a symptom of one of (1, 2) the incidents that we’re currently wrangling on GitLab.com. I’d keep an eye on those and let us know if you’re still seeing the issue once we’re declared the all clear on both.

3 Likes

@tristan, it seems that one of the two issues you noted is resolved (?) but still not able to get to branches.

The situation has resolved. I checked for incidents before posting but did not see any. It’s good to know that the GitLab team was on it.

Unfortunately, the situation has not resolved for me. I am still getting this.


And, as far as I can tell, the first gitlab provider issue has not been resolved:
https://status.gitlab.com/pages/incident/5b36dc6502d06804c08349f7/5ef4cda929ccab04bfc12c61

I’m still getting this today as well.

I’ve had this problem related to my own login issues, see this forum thread:

1 Like

We are experienceing the same issue for some users with our Gitlab CE. We upgraded from 12.10 to 13.1 last week.

UPDATE: It does work in Firefox but not with the new Edge Browser or via git clone in WSL or inside a Docker Container.

@ngeorgas @arcandio As GitLab.com users, are you still seeing this issue?

1 Like

I am not, personally, but I’ve not been on Gitlab as much the past few days.

1 Like

No, not for the past week or so.

1 Like