External_url is getting timed out in gitlab setup in azure

Gitlab succesfully installed and got following message:
Thank you for installing GitLab!
GitLab should be available at http://gitlabtest.uaenorth.cloudapp.azure.com
For a comprehensive list of configuration options please see the Omnibus GitLab readme
README.md · master · GitLab.org / omnibus-gitlab · GitLab
Help us improve the installation experience, let us know how we did with a 1 minute survey:

But when tried to access it using that url (http://gitlabtest.uaenorth.cloudapp.azure.com) its getting timed out

Please check that allow inbound access to your instance within Azure for HTTP port 80 and HTTPS port 443. I don’t have experience of Azure, but Amazon EC2 doesn’t allow inbound traffic until you configure it to do so. Therefore I expect Azure to be the same. These ports at present aren’t accessible.

You can also check this on your Azure instance to make sure gitlab is listening:

netstat -tunlp | grep 80
netstat -tunlp | grep 443

so depending on your external_url if it is using http or https, check verify these ports to ensure gitlab is running, as well as inbound access from your Azure instance configuration.

Thanks for the comments…I have attached the result of that command with this.

Inbound traffic is already enabled.

Better would be to run it as root, then we can see what process name is for port 443.

Also, as root user run:

gitlab-ctl status

so we can see if services are running. Anyway, I don’t think inbound access is unblocked, since I tried telnet to port 80 and 443 for your hostname, and it doesn’t connect. So this means access is still restricted. Since port 443 is running on your instance, it should have accepted the connection which it doesn’t.

So this is still a firewall/inbound access problem.

This is what I am getting.

This is what I am getting after running that command

I configured a new VM (gitlab-ce-test.uaenorth.cloudapp.azure.com), same issue persists

So gitlab is running, just not accessible. So a firewall or something is blocking it. As root on the vps:

iptables -nL

if the rules are empty with accept, then that means no local firewall is causing a problem. If we have rules, then we will need to configure something but it depends what version of Linux was used, as don’t know if you used, CentOS or Debian/Ubuntu. If CentOS, then firewalld could be running, if Debian/Ubuntu, then it shouldn’t be a firewall issue locally.

Creating a new instance won’t solve the problem, it will have the same characteristics if the firewall/ports are not unblock - which as I’ve tried the ports are not accessible.

So gitlab is fine - this problem is nothing to do with gitlab, you just need to sort out the firewall/port access.

Its empty.

This is the image details

OK, so like I wrote a few times already. Azure is not configured correctly to allow inbound access to your instance on it’s public IP address.

Ok…when I tried to use this from my mobile I am able to see login page…looks like https redirection was the problem.
But this time its not showing password change screen for admin , just showing the login screen.
Then I signup new user then its showing admin should accept the user.

So whats the default admin credentials and how to change that now?

Please read the install docs before attempting an install:

 3. Browse to the hostname and login

On your first visit, you'll be redirected to a password reset screen. Provide the password for the initial administrator account and you will be redirected back to the login screen. Use the default account's username root to login.

See our documentation for detailed instructions on installing and configuration.

use root and set your password asap.

Yes I am following gitlab document only. But unfortunately I am not getting the same results as mentioned in the document.

As I mentioned in my previous email for first time login I am not getting password reset page. It’s going directly to login page.

But according to documentation as you mentioned its supposed to go to password reset for admin.

Finally managed to got it work…The issue looks like is there in gitlab-ce bitnami version.
But when I used the gitlab enterprise in azure without doing any other changes it worked.

Thanks to @iwalker for all the support.

1 Like