Failed to pull gitlab-docker-helper

I have configured docker executor for my gitlab project. Gitlab server version - 14.10.5-ee. I noticed the executor was not online and tried to restart the underlying instance. Still it didn’t help much. And I tried update the runner after checking over few blogs.

  • Should result in successful execution of the job after getting allocated to the runner
  • Job failed: Error response from daemon: pull access denied for gitlab-runner-helper, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied (executor_docker.go:166:0s)"
  • What version are you on? Are you using self-managed or
    • *GitLab - 14.10.5-ee *
    • Runner - Tried 15.10 and 14.10.0

As of now I tried below things to overcome the issue

  • Tried pulling the docker helper image manually by checking on the the revision number
  • Used helper property to override the default docker helper image used

Thanks for any suggestion/solution.