Failed to write (No space left on device) on a fresh Ubuntu server 60GB install


I’m trying to install Gitlab.

Installed Ubuntu Server 18.04 on a Hyper V host VM. The VM has 8GB RAM and a 60GB fixed VHDX hard drive.

I’ve tried to install this 4 times on Ubuntu, each time remaking the VM and installing Ubuntu Server and then trying to install Gitlab but everytime I hit the same error as follows:

sudo apt-get install gitlab-ee
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 733 MB of archives.
After this operation, 1,936 MB of additional disk space will be used.
Get:1 bionic/main amd64 gitlab-ee amd64 12.1.1-ee.0 [733 MB]
Fetched 733 MB in 3min 31s (3,482 kB/s)
Selecting previously unselected package gitlab-ee.
(Reading database ... 67242 files and directories currently installed.)
Preparing to unpack .../gitlab-ee_12.1.1-ee.0_amd64.deb ...
Unpacking gitlab-ee (12.1.1-ee.0) ...
dpkg: error processing archive /var/cache/apt/archives/gitlab-ee_12.1.1-ee.0_amd64.deb (--unpack):
 cannot copy extracted data for './opt/gitlab/embedded/service/gitlab-rails/doc/ci/examples/laravel_with_gitlab_and_envoy/img/pipelines_page.png' to '/opt/gitlab/embedded/service/gitlab-rails/doc/ci/examples/laravel_with_gitlab_and_envoy/img/pipelines_page.png.dpkg-new': failed to write (No space left on device)
No apport report written because the error message indicates a disk full error
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Okay I have fixed it myself.

For some reason Gitlab throws an error during install when the HDD is using LVM.

So, I created a new VM with no LVM and it installed fine.