Favicon works on other hosting services but not gitlab

Describe your question in as much detail as possible:

I have a favicon that shows up when im using other hosting sites like netlify or github pages BUT it is simply not showing up in my gitlab pages page!

  • What are you seeing, and how does it differ from what you expect to see?
  • Consider including screenshots, error messages, and/or other helpful visuals

I am seeing this: Screen Shot 2021-03-20 at 10.50.00 PM

When I should be seeing this: Screen Shot 2021-03-20 at 10.50.04 PM

  • What version are you on (Hint: /help) ? and are you using self-managed or gitlab.com?
    I’m using Gitlab.com

  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?

I have tried this but that didn’t work: html - Favicon not showing up - Stack Overflow

I wanted to try this but couldnt find appearance… i think its a paid feature? : how to change the favicon( logo) in gitlab manually - Stack Overflow

I havent tried this and Want to try it but im not sure how to do that… like where do you call bash from and if anyone knows, is this the right way to get my favicon to show or is there a better way: Change GitLab branding logo and favicon - TienLe's Blog

<link rel="icon" type="image/png" sizes="32x32" href="img/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="img/favicon/favicon-16x16.png">
<link rel="manifest" href="img/favicon/site.webmanifest">
<link rel="mask-icon" href="img/favicon/safari-pinned-tab.svg" color="#5bbad5">
<link rel="shortcut icon" type="image/x-icon" href="favicon.ico">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="theme-color" content="#ffffff">

Here is the code for my favicon ^

Favicon is located here:

Screen Shot 2021-03-20 at 10.57.34 PM

Any help would be greatly appreciated :smiley: im new here, just switched over from github pages (storage limitations too low) → netlify (will incur automatic charges if bandwidth is over used) → here (gitlab) < wont incur charges; has generous space so… even if my favicon wont work… its a smol price to pay i guess :3

Idk how to mark this as “answered” but basically i removed all the files and reuploaded them and the favicon shows up now yay :smiley: