Fingerprint in 2FA on Linux

I’m running Linux Mint 20.3 and Firefox 104
I enabled 2FA in my account. I use a security key for this.

I actually have a dual-boot with Windows. I once try to log in with Firefox 104 on Windows 11.
It worked. When I went to 2FA management page, and clicked “Add a new device”, it popped up a “Windows Hello” dialog to use the fingerprint sensor as an authenticating device.
I did it and it worked. When using Windows, if I connect to, I just need to type my password and scan my fingerprint and I’m in, no more requiring the security key.

Although the same machine, the same thing does not work on Linux.

  1. Is it expected ?
  2. Can you explain why ?

Thank you

  • Consider including screenshots, error messages, and/or other helpful visuals
    Hello dialog
    It’s in French, but I guess the sentences are pretty clear.



I searched for compatible systems, but was not able to find how encrypted devices like fingerprint stores or facial recognition systems can be declared as supported devices for MFA through browser.
All mentions I found were to include this in the login process through PAM (e.g. facial recognition)