Git clone gitlab repository- fatal does not appear to be a git repository

Gitlab 8.6.6 running on mint Linux. I have added jenkins ssh key to git user authorized_keys file and can log on as git when I “ssh mint-gitlab” whilst as jenkins.
Created project in gitlab. From my PC, as my user, can clone the project.
But as user on mint, get following.
jenkins@Mint-Gitlab /tmp $ git clone git@Mint-Gitlab:norricorp/groovyTest.git
Cloning into ‘groovyTest’…
fatal: ‘norricorp/groovyTest.git’ does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Repository is there and this command works on windows as me. Both myself and Jenkins are members of a group which is known to the project. The project is private.

So does anyone know why I get this error with gitlab generated repositories.

What happens if you try to clone using an https url? You have your local mint system’s ssh key generated and added public bits to gitlab, and you say you can start ssh shell but can’t clone with ssh? You might want to turn on some verbose logging to see where its dying.

I think something like:
GIT_SSH_COMMAND=“ssh -v” git clone example

Where I have seen issues like this it’s a certificate trust chain issue.


Using http works - I enter the username and password.
Running the ssh clone with verbose logging produced nothing extra - just the same messages above.

I wonder if there’s something funny in your network.

That is a distinct possibility but actually, in this case, there are only two machines - mint VM (running gitlab, git, maven and Jenkins) and a windows PC. So there is no networking as it is cloning the gitlab repo on the VM that is failing.
I think it is because the ssh keys have gone wrong.
For instance, I tried adding the ssh key for linux jenkins user to the ssh key dialog for the jenkins user in gitlab. There were no keys associated with the user. Add the key and it errors with “Key has already been taken. Fingerprint has already been taken” and so ssh keys remain at zero.
Can you think why this is and how I can remove the key so that it will accept a key for jenkins user?

So the problem was that I had not added the key to gitlab for jenkins user. I had added it directly to the authorized_keys file but of course it did not have the “command=…” prepended to the key.
I regenerated the key and added it to jenkins via gitlab and can now clone

i have the same issue.
I run:
git clone
fatal: ‘name/scripts.git’ does not appear to be a git repository
fatal: Could not read from remote repository.
git clone

it works fine.