Git commit issue after creation of project


I have a question regarding my account.
I successfully set up three projects in my free account @ Gitlab.
Access via web interface and git command line works perfectly.
However, the fourth project I added behaves somewhat strange.

I was able to finish the project create wizard on
cloning the project’s repository also worked fine. But as soon
as I try to commit and push some files to the repo, I receive
an error message which says

remote: GitLab: You are not allowed to push code to protected branches on this project.

The behaviour on command line and web interface is the same.

Is this due to some limitation of my account?


I have the same issue here,
looks like they have some problems currently.

When I try to commit I get the same error, and even from the web interface I cannot add files to the repo.

Furthermore when I go back to the list of my projects the repository is not listed there but when I type in the url manually
I can see the repo but I can not do anything there. Hope it is fixed soon.


thanks for this reply. I will keep on trying for the next days.

As additional information I’d like to point out that existing projects do not seem to be concerned, this is related to newly created projects only

See here:

This problem should be fixed now, though you may need to delete the project and create a new one.

Problem is fixed. Thanks a lot.
I had to re-create the project in question.