New gitlab.com project: cannot push

I created a new project and tried pushing to it from existing files on my computer. However I am getting the message “You are not allowed to push code to protected branches on this project”. I’ve tried going though the instructions that are displayed after creating a project a number of times, but I keep getting the same error.

The error also says “[remote rejected] master -> master”. I am using the command “git push -u origin master” as per the instructions.

I also cannot switch to “Protected Branches” in the project settings - when the page reloads, I just see the post-creation instructions again.

Any help would be appreciated

This seems to be related to my problem:

Yes, it seems to be the same. And the second poster encountered the same issue as I did with the project not being visible in the list.

I have around 12 projects on gitlab.com and I haven’t had this problem before.

What are your user rights? Because in default configuration (if I remember right) nobody except Project Owner can push to protected branches (master by default is a protected branch)

The credentials I am using to try to push to the project are the same I use to log into gitlab.com.

See here: https://gitlab.com/gitlab-com/support-forum/issues/1425

This problem should be fixed now, though you may need to delete the project and create a new one.