Gitlab 8.9 omnibus - still can not use build emails - generic "we tried" error message on test

For several versions now it seems that the SMTP integration build-email feature is totally broken.

I have tried a local anonymous smtp, and remote anonymous smtp, and an smtp+tls login (gmail) and nothing works. The same rather useless error appears when I click the test button in the builds email feature:

We tried to send a request to the provided url but an error occurred.

There is nothing in the logs that I can see using gitlabctl-tail that indicates we even TRIED to do any smtp communication. Instead I think the test button is utterly broken, and that whatever should happen when you click that test button is just not working.

This is on Ubuntu 14.04 LTS, with Gitlab CE omnibus packages from

The gitlab.rb is absolutely vanilla, with external_url configured, and everything else at defaults (commented out) except whatever smtp settings.

This problem is specific to the CI Builds Emails features. The problem does not affect the Email On push.


Update: It looks like this bug was logged 5 months ago and is getting no love.

Looks like it’s getting some love and should get fixed in some 8.x future release soon. Maybe 8.11.