GItlab as Omniauth provider, always says "The redirect URI included is not valid."

I have an rails application that have
login with gitlab function
but when I trying to login with gitlab it always give this error message

An error has occured
The redirect URI included is not valid.

I use this gem as my omniauth strategy

I have tried to use and my own gitlab(using GDK) but still it give same error messages

1 Like

I’m answering because I have seen this in several cases, and only have some general ideas:

  1. It is possible that gitlab itself is not configured correctly.

  2. It is possible that you need a secret token or something like that, and the redirect URI includes a token-like value that is not valid.

  3. It is possible you might have to retry the “pairing” of your omnibus mattermost and omnibus gitlab like it discusses inside the omnibus config (gitlab.rb) file. There is a gitlab_secret and gitlab_id value, which you might have to regenerate or manually place into gitlab.rb

Have you ever fixed this?

iirc I have managed to fix this problem

here is the issue in github page