Gitlab-ce docker image - how to enable Mattermost?

Hi guys,

I don’t deny that I am not the sharpest tool in the shed, I can’t figure out / “google out” how to enable Mattermost in the giltab-ce omnibus docker image. I have been getting similar results on the latest gitlab-ce docker image running docker on Debian 8 and on gitlab-ce:9.4.2-ce.0 running docker on fresh Gentoo install (I dont’ think that matters though)

  • Based on the Gitlab-ce Docke image document I have tried to enable the “gitlab_externar_url” in gitlab.rb (pointing to DNS record pointing to the same server) and restarting the docker image. No Joy. On closer inspection, the 8065 port isn’t even open inside the docker instance, mattermost log keeps returning: [EROR] Failed to ping DB retrying in 10 seconds err=pq: role "gitlab_mattermost" does not exist. If I visit domain, I see gitlab login.

  • Based on the Gitlab Mattermost document, I ran sudo gitlab-ctl reconfigure inside the docker image and I am seing the 8065 port open and when creating groups in gitlab I am seeing the “Create Mattermost Team” option on the screen. But If I leave the option checked, I can’t create the group: I end up with error 500. Mattermost log is clear. Also visiting the domain setup in gitlab.rb file still shows me a gitlab login page…

Can you please point me to what I am doing wrong?

Just had the same problem on the docker variant. There might be some errors in the documentation, made at PR. Gist is that the documentation seems to be missing the mattermost['enable'] = true setting that must be set.

Also make sure to follow through with the “Manually (re)authorising” step as it does not seem to create the application authorization automatically.


thank you for the “push” in the right direction. Now I can see the Mattermost login page. In my oppinion the correct order might be:

  1. start the gitlab docker image
  2. create application authorization from the root account in the gitlab web interface. (Scope API)
  3. edit the gitlab.rb, uncomment/ fill in:
    a) mattermost_external_url
    b) mattermost[‘enable’] true
    c) mattermost['gitlab… - everything related to the created application in step 2
  4. reconfigure gitlab (restarting docker will not help). First connect to the container docker exec -it /bin/bash and then run the reconfigure gitlab-ctl reconfigure.

After these steps I can see the mattermost login page as expected.