Gitlab CE - Smtp settings - SMTP-AUTH requested but missing secret phrase

Hi,

Here is my configuration in gitlab.rb

gitlab_rails[‘smtp_enable’] = true
gitlab_rails[‘smtp_address’] = “mysmtp.server”
gitlab_rails[‘smtp_domain’] = “mysmtp.server”
gitlab_rails[‘smtp_port’] = 25
gitlab_rails[‘smtp_tls’] = false
gitlab_rails[‘gitlab_email_from’] = ‘NO-REPLY@email.com’
gitlab_rails[‘smtp_openssl_verify_mode’] = ‘none’
gitlab_rails[‘smtp_enable_starttls_auto’] = false
gitlab_rails[‘smtp_ssl’] = false
gitlab_rails[‘smtp_force_ssl’ ] = false

The configuration of my smtp server is that it does not ask for a password.
However, when I try

irb(main):006:0> Notify.test_email(‘me@email.com’,‘Hello World’, ‘This is a test message’).deliver_now
Notify#test_email: processed outbound mail in 2.0ms
Sent mail to me@email.com (4.0ms)
Date: Fri, 31 May 2019 12:15:59 -0400
From: GitLab gitlab@172.0.1.2
Reply-To: GitLab noreply@172.0.1.2
To: me@email.com
Message-ID: 5cf1533fa4b2f_46ef3fcd7a7dc5f8367b@localhost.localdomain.mail
Subject: Hello World
Mime-Version: 1.0
Content-Type: text/html;
charset=UTF-8
Content-Transfer-Encoding: 7bit
Auto-Submitted: auto-generated
X-Auto-Response-Suppress: All

This is a test message

Traceback (most recent call last):
16: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/actionmailer-5.0.7.1/lib/action_mailer/message_delivery.rb:95:in deliver_now' 15: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/actionmailer-5.0.7.1/lib/action_mailer/rescuable.rb:15:inhandle_exceptions’
14: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/actionmailer-5.0.7.1/lib/action_mailer/message_delivery.rb:96:in block in deliver_now' 13: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/mail-2.7.1/lib/mail/message.rb:260:indeliver’
12: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/actionmailer-5.0.7.1/lib/action_mailer/base.rb:541:in deliver_mail' 11: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/activesupport-5.0.7.1/lib/active_support/notifications.rb:164:ininstrument’
10: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/activesupport-5.0.7.1/lib/active_support/notifications/instrumenter.rb:21:in instrument' 9: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/activesupport-5.0.7.1/lib/active_support/notifications.rb:164:inblock in instrument’
8: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/actionmailer-5.0.7.1/lib/action_mailer/base.rb:543:in block in deliver_mail' 7: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/mail-2.7.1/lib/mail/message.rb:260:inblock in deliver’
6: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/mail-2.7.1/lib/mail/message.rb:2159:in do_delivery' 5: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/mail-2.7.1/lib/mail/network/delivery_methods/smtp.rb:100:indeliver!’
4: from /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/mail-2.7.1/lib/mail/network/delivery_methods/smtp.rb:109:in start_smtp_session' 3: from /opt/gitlab/embedded/lib/ruby/2.5.0/net/smtp.rb:518:instart’
2: from /opt/gitlab/embedded/lib/ruby/2.5.0/net/smtp.rb:546:in do_start' 1: from /opt/gitlab/embedded/lib/ruby/2.5.0/net/smtp.rb:780:incheck_auth_args’
ArgumentError (SMTP-AUTH requested but missing secret phrase)

Does anyone have any clue about how to fix this issue ?
I am puzzled because I did not expect the smtp to require a secret phrase as my smtp does not require a password when I set it up for tools such as Jira

This has been solved. There was an authorization to request for the smtp server to accept the email from my gitlab server.