Gitlab.com AutoDevops deployment failing with: "Please enter Username"

Yesterday my AutoDevops to GKE pipeline deployed fine. Today when I run it the deployment fails saying:

$ ensure_namespace
Please enter Username: Please enter Username: Please enter Username: error: EOF
Please enter Username: Please enter Username: error: EOF
ERROR: Job failed: exit code 1

Any ideas why this would be? My current suspicion is it’s a bug on Gitlab’s side - I can’t find any past reference to this problem on Google.

3 Likes

@ryan1
same issue here, started getting these errors 7 hours ago, any luck with troubleshooting?

@ryan1

removing kubernetes integration from project and integrating it again fixed the issue, no config updates required, hope that helps anybody!

(if not helps the only differ may be that I also upgraded my k8s nodes to check if that was an issue, so may be it’s related somehow)

2 Likes

I was getting the same error and also needed to remove and add again the k8s integration. Does anyone know how I can tell gitlab that tiller is installed?

You don’t need to do that. When you add an already existing Kubernetes cluster to a gitlab project it doesn’t update the information about which applications are installed. But once you deploy it will discover tiller automatically.

1 Like

Umm ok, doesn’t work for me but I am using a custom gitlab-ci.yml file as this is a dotnet project and auto-devops doesn’t really support that to well.

Will have to look into it.

edit: it deploys fine to the k8s cluster.

This appears to have fixed itself now - I did also update my k8 cluster to the latest (kubernetes) version before it started working for me.

1 Like