Gitlab.com - no options for confidential merge+branches

According to the documentation, as of GitLab 12.1, create confidential merge request and branch should be available https://docs.gitlab.com/ee/user/project/issues/confidential_issues.html. However, this isn’t the case on the hosted instance at gitlab.com. This option isn’t provided. On non-confidential issues, there is a branch creation option though. I also tried with GitLab Next and GitLab Gold.

What am I missing?

I was just involved with some confidential issues on a project on gitlab.com, and the “create confidential merge request” button did appear. Pushing it gave me the option to create a branch or create one and merge it. But regardless of which one I selected, I got an error saying that it failed and that I should try again. And of course trying again didn’t help. We ended up manually (non-confidentially) merging the branch with the fix, since once we merged confidentiality wasn’t needed any more.

I wasn’t sure if I was just in the wrong role or something to do the merge, but it doen’t seem like that was the case. Better documentation (and testing) of the confidential merge request feature is badly needed.

Hi @jimfenton! I definitely hear what you are saying about GitLab’s opportunity to improve the documentation on confidential merge requests.

I have taken this to the docs team to see what we can do, so don’t be surprised if I reach out to you again for ideas. :wink: Of course, if you do have specifics to share on that front, feel free to reply below.

Thanks so much!

Better documentation would definitely help, but more specific messaging in GitLab is needed as well. The message to the effect that the creation of my merge request had failed was very unhelpful – I still don’t understand what, if anything, I had done wrong (and I tried a lot of different things to create the merge request). I still wonder if it was a bug in GitLab or an error on my part.

@jimfenton thanks for reporting this!

more specific messaging in GitLab is needed as well.

Exactly, 100% agreed. :slight_smile:

I opened an issue to follow up: https://gitlab.com/gitlab-org/gitlab/issues/39138. Could you please take a look there and give us more detailed information about the error?

1 Like

Anything new on this? I would like for others with “user” permission to be able to create a confidential issue on my project and initiate a confidential merge request.
The “create confidential merge request” button is not appearing in the issue when they view it…