GitLab crashing wih 502 after a day

I have running GitLab in a docker with the official GitLab-CE docker image. The operating system is UnRaid version 6.8.3. The server has 40 cores 128 GB of ram and 7 TB of Storage. Over night the server is not occupied. My problem is that GitLab is crashing every time after one day with the website error 502. After “gitlab-ctl restart” it works fine again.

sideqik current log:

The GitLab version I’m using should be 12.9

I tried to assign more unicorn workers. Currently I have assigned 10 workers with a timeout time of 120s.
I also tried serveral other things, which forgot about. These more or less haven’t worked.

I hope you’re abled to help me :smiley:

I solved the issue by my self.
In my situation I run my gitlabserver in a docker container on an unRAID-server. The default template of the docker container provided in the “Community Applications” plugin had selected a cached share. After 24h my server is going to move the files from the cache drive to the array and causing some kind of problem in gitlab.
After I moved my gitlab installation off the cached Share onto a non cached, everything worked just fine.

I hope this helps someone :smiley: