Error 500 or 502 after a restart

hi all!
I’ve installed the latest gitlab into my server and I’ve got this issue: the webpage gives the error 500 or 502… the only solution is to change the file gitlab.rb, reconfigure the server and NOT restart the server, otherwise I got the errors…

have you got any ideas about how to understand my issue?

thanks in advance

Gitlab 10 has a bug that’s currently being worked on now. Recommend that you version down to Gitlab 9 until it is fixed.

thanks @hozawa … so I prefer to wait that’s been solved!

1 Like

Yesterday I realized that the issue persists even with GitLab CE 12.6.1 using Docker images! the solution proposed in this GH issue solved the problem for me

docker exec -it gitlab rm /opt/gitlab/var/unicorn/ && docker restart gitlab

I’ve put that in my host cron file and it works!

Maybe it will work if you use standard GitLab installation without docker

I have gitlab 14.4.1 and get the given error. I installed as a container from: GitHub - sameersbn/docker-gitlab: Dockerized GitLab