Gitlab Docker Container with custom GitLab-CE fork

(I did not want to open an issue at gitlab-ce because it seems like it is not a place for questions. I hope this is the correct place to ask this question and I hope someone here can help me.)

My goal is to have our own GitLab fork within a Docker container. I have tried to use the gitlab/gitlab-ce:latest container and replaced the gitlab-rails folder within. I stumbled upon quite a few issues and did not get that to work.
My current approach is to use a ubuntu:18.04 image and install gitlab from source within that container. The installation seems to be successful. When the installation is done and I run sudo /etc/init.d/gitlab restart neither port 80 or 8080 are open and using curl on localhost does not work. It seems like the gitlab.yml config file is ignored. I use the following settings within that file:

[...]
gitlab:
    ## Web server settings (note: host is the FQDN, do not include http://)
    host: 127.0.0.1
    port: 80 # Set to 443 if using HTTPS, see installation.md#using-https for additional HTTPS configuration details
[...]

So I updated the puma.rb file with bind tcp://127.0.0.1:8080 and restarted gitlab. Using curl on localhost now returns the login page. But even though I forwarded the 8080 port to 8080 with docker run -p 8080:8080 <...> the gitlab instance is not accessible from the outside.
Why is that so? I have tried to solve this issue for multiple days and I simply don’t know what to do.

I am new to ruby and gitlab, so the entire codebase is new to me. Am using the right approach to host a gitlab fork within a docker container or is there an easier way to do that? If my current approach is the correct one, what am I doing wrong?