Gitlab export errors between gitlab instances


I am in the process of migrating projects between two internally-hosted gitlab servers, both recently upgraded to 8.12.3. Previously, I was running 8.11.5 on both instances.

With 8.11.5, a particular project’s export/import worked ok, but tags and milestones were not remaining connected to issues after the import (as noted in a separate issue here which is now closed 19510 ). I saw that this was getting fixed in 8.12, so once we upgraded both servers to 8.12.3, I re-ran the export on the old server which completed fine. However, when I went to import the project on the new server, I received a “undefined method `’ for nil:NilClass” error, similar to this issue on gitlab-org (

I’m happy to provide an excerpt of our production.log with the stack trace. I tried a few other projects for gitlab export / import, and they worked fine; so it is definitely tied to the particular project, which imported/exported successfully in 8.11.5 (except for labels / milestones issue), and now in 8.12.3, the import/export does not work.

Any help / suggestions appreciated!