Import repo from self-hosted to

As a test to migrate our gitlab-ce self-hosted repos to, about a month ago I took a handful of repos, did the export/import procedure. Worked great and very fast. I don’t recall what version was running then.

We’re ready to do the actual migration so I did the same repo export/import procedure. The first repo I tried now is stuck in “Import in progress.” The repo was one of the repos I tested earlier which imported very quickly. Our gitlab-ce is at 13.2.4 now.

Anyone able to do recent repo imports with export files from a current self-hosted gitlab? It feels like something’s “stuck” but I don’t know how to verify that with

I find similar topics when I do a search but most are old issues that were fixed or current forum posts w/o replies.


This time around instead if being stuck with the Import in progress message, it’s now erroring out. I’m now getting a “…undefined method `local?’ for nil:NilClass” error. I find that error for other people like and it seems to be a version mismatch. Our self-hosted is at the latest rpm so I don’t know what we can do to match our version to

Hey @tyuhas, welcome to the GitLab Community Forum! :tada:

This sounds related to a recent known issue regarding project imports to from the latest version. Since you raised this topic though the matter should be resolved though, so please try again if you haven’t already.

Thanks @Tristan ! It does appear to work now for me!

1 Like