Gitlab Runner Helm Chart + Minio cache server not working

Hi everybody,

I am running a gitlab-runner in a Kubernetes Cluster launched by the official Helm Chart of Gitlab (version 0.4.0-rc1).
The runner is working, pods are spawned to build my projects with gitlab-ci.

Next step I wanted to take was to activate distributed caching, so I spawned a minio server (version RELEASE.2019-03-13T21-59-47Z)in my kubernetes cluster which is running fine, I can login to the web ui with my accesskey and secretkey.

However I cannot get the gitlab-runner to use the minio cache server. On every job I get the following error message in gitlab-runner’s log (not in the job):

ERROR: error while generating S3 pre-signed URL error=Get http://169.254.169.254/latest/meta-data/iam/security-credentials: dial tcp 169.254.169.254:80: i/o timeout

This is the cache part of the configuration I used with the gitlab-runner helm chart:

cache: 
  #   ## General settings
    cacheType: s3
    cachePath: "runner"
    cacheShared: true

  #   ## S3 settings
    s3ServerAddress: REDACTED:9000
    s3BucketName: k8-runner
    s3BucketLocation: us-east-1
    s3CacheInsecure: true
    secretName: s3access

I tried without s3BucketLocation, same result.

I can’t find any information about similar problems anywhere and would appreciate any help.

Thanks!
Michael

I solved the problem. Reason was simple:
The secret was not in the same namespace as the gitlab-runner workload.

The description after creating the secret with the example code from the gitlab documentation file was misleading, as it stated that it was “available from all namespaces” which is obviously incorrect

After creating the secret again in the same namespace, it worked