Gitlab-runner in user mode doesn't start automatically after reboot

We’re running gitlab 16.1.0 with newly installed gitlab runner 16.1.0 on Ubuntu 22.04.2 LTS.
I’d like to have our Gitlab runner in user mode.
This works but I don’t get the gitlab-runner automatically started after a reboot.

When I run the command to start the gitlab runner in user mode, this works:

To get the command running after a reboot, I’ve edited the /etc/systemd/system/gitlab-runner.service file to the following:

After performing a reboot of the Ubuntu host with the gitlab runner installed, the service seems to be up but it isn’t picking up jobs from CI/CD.
Systemctl status gitlab-runner.service

CI/CD job keeps in pending state:

However, when I run the command:
/usr/local/bin/gitlab-runner run --working-directory=home/gitlab-runner

The job immediately gets processed.

Ok, guys, I’ve came to realisation that I also had Gitlab support and asked them the same question.
Turns out, this works as designed.

Case closed! :slight_smile: