Gitlab Runner is locked

Describe your question in as much detail as possible:
I have a GitLab runner that is running on EC2 Instance on AWS.
After a long time that the runner worked without any problems, it suddenly stopped executing jobs, and I see that it has a locked tag.

  • Consider including screenshots, error messages, and/or other helpful visuals

Already tried to re-register the runner but it still locked.


The “locked” tag means it can only be used by specific projects.

You haven’t said much about your environment, but I guess having a runner on an EC2 instance implies that you’re using I have no idea how you can configure runners on that, but I guess you mostly want your runners to be locked to your own projects. But on standalone GitLab instances, you can edit a runner in the admin area, that includes (un-)locking it/changing which projects it is locked to work on.

I have the same issue, using Any group runner I register ends up locked and I can’t manage to unlock it, and any project runner works fine. Is there a way to use group runners ?

I’ve had a similar issue due to a recent upgrade. Try passing --locked=false when registering the runner.

I also used chrome inspect element to remove the tag hiding the checkbox and was able to adjust the setting. After a save the setting stayed applied, there must just be a UI disabling interaction with the checkbox.

This at least will allow you to edit the runner without recreating it.


1 Like