Gitlab SaaS push - HTTP 500 curl 22

:hugs: Please help fill in this template with all the details to help others help you more efficiently. Use formatting blocks for code, config, logs and ensure to remove sensitive data.

Problem to solve

Describe your question in as much detail as possible:

  • What are you seeing, and how does that differ from what you expect to see?
  • Consider including screenshots, error messages, and/or other helpful visuals

Similar to Error when i push in GITLAB (RPC failed; HTTP 500 curl 22 The requested URL returned error: 500 Internal Server Error)

I’m using an access token. This token is used as I can see the last used time and is correct.

Steps to reproduce

Which troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?

Git add
Git commit
Git push

git push origin main
Enumerando objetos: 485, listo.
Contando objetos: 100% (485/485), listo.
Compresión delta usando hasta 4 hilos
Comprimiendo objetos: 100% (289/289), listo.
error: RPC falló; HTTP 500 curl 22 The requested URL returned error: 500
send-pack: unexpected disconnect while reading sideband packet
Escribiendo objetos: 100% (350/350), 5.54 MiB | 4.07 MiB/s, listo.
Total 350 (delta 95), reused 0 (delta 0), pack-reused 0 (from 0)
fatal: el remoto se colgó de manera inesperada
Everything up-to-date


Provide screenshots from the GitLab UI showing relevant configuration, if applicable.
On self-managed instances, add the relevant configuration settings or changes.

The origin is set as


Please select whether options apply, and add the version information.


GitLab Enterprise Edition 17.0.0-pre 31b98f0baf2

Helpful resources

  1. Before opening a new topic, make sure to search for keywords in the forum search
  2. Check the GitLab project for existing issues. If you encounter a bug, please create a bug report issue.
  3. Troubleshooting docs: Self-managed GitLab instances.

Thanks for taking the time to be thorough in your request, it really helps! :blush:

I tried deleting and creating again the repo with the same name, but I get exactly the same result.