Gitlab self managed instance restore

I have a gitlab ee self managed instance (Version 16.8.1) which is now up and running. I have taken full backup of it using.

• sudo gitlab-backup create

I got the backup and it contains every files i hope, including the repositories. Now i need to restore it to a new server which i have installed as fresh and setup with same version as the running or source gitlab instance.

Then i performed the restoration steps as mentioned in this document.

Moved the backup file to /var/opt/gitlab/backups
Renamed it with ending _gitlab_backup.tar
Made git as the owner for this folder
Stopped puma and sidekiq
then performed the restore command

sudo gitlab-backup restore BACKUP=

The restoration step is working, by the way an error is showing in the first when database clearing is performed

Restoring PostgreSQL database gitlabhq_production … ERROR: must be owner of extension pg_trgm
ERROR: must be owner of extension btree_gist
ERROR: must be owner of extension btree_gist
ERROR: must be owner of extension pg_trgm

After this the restoration is compled. Then i replaced the destination gitlab instance gitlab.rb and secrets.json with source server file of the same name.

After that i restart the gitlab instance.

When gitlab instance is up i could able to login, my ssl works,projects,users all are listing as fine. But when i open any project it is showing ‘no repository’

When i check the /var/opt/gitlab/git-data/repositories
It is containing only +gitaly folder. no @groups or @hashed folder. Which is there in the backup file i double checked.

Then i manually copied the @groups and @hashed folders to /var/opt/gitlab/git-data/repositories
and restart and reconfigure the gitlab but no luck,still the same.

then i performed sudo gitlab-rake cache:clear
still no luck.

What is the issue, am i missing anything or is this a known with some altrenative solutions