GitOps will not sync repo

I have tried many times over several clusters (k3s, AKS and LKE). I can see the gitlab-agent in the gitlab-agent namespace sees the config.yaml applied, but will not sync objects. I followed the helm install steps (the terraform module i found in another guide is missing now).

helm upgrade --install gitlab-agent gitlab/gitlab-agent --namespace gitlab-agent --create-namespace --set config.token=F*******************************g --set config.kasAddress=wss://

The config.yaml used:

  - id: isaac.johnson/dockerWithTests2
    default_namespace: gitlab-agent
    - glob: '/k8s/*.yaml'

i tried with and without a preceding slash, the project ID as well.

The repo itself is public:

and i subsequently used the k8s folder with ArgoCD w/o issue (k8s · main · Isaac Johnson / dockerWithTests2 · GitLab)

Full writeup here: Gitlab Revisit: Part 3 - Fresh/Brewed (2nd half) - which is a candidate post for next week.

Anything I might have missed? I Really want to see GitOps work with K8s inside of Gitlab but seem rather stuck

1 Like