Help: GitLab merge is hung/stuck for forever!

The merge request is hung for forever, I don’t understand why. I don’t know who to approach to fix this. Please help.

1 Like

same problem, I suppose the update to GitLab 17 caused the problem. GitLab CE 17.0.

Can you try to downgrade to previous version and feedback if it helps?

Hi @sdudnic_ingerop: Thank You for the help.

But, I figured that it was failing because of the bigger file size, for which the “git diff” was stuck.
I removed the large file and re-tried and it worked, and alter I manually updload large file.

in our case ANY merge request is working anymore After difficult update to 17.0 merge requests not working (#462430) · Issues · / GitLab · GitLab

not related, but in your screenshot, how a ticket can be in the same time a “bug”, an “enhancement” and a “feature”? :slight_smile:

I hope GitLab fixes it ASAP.

For my case, this thread help: Problems to create merge requests (#438380) · Issues · / GitLab · GitLab - check if it of any help.