How to integrate gitlab xcode 10

How to integrate gitlab xcode 10. I try to clone from xcode 10 project but it shows wrong account or access token. but i am sure my token and account not wrong. how to solve this or connect with gitlab and xcode ios project

Same issue! What’s token?! Is not the user and password?

ok the solution!:

1 Like

Unfortunately, something else still goes wrong.
I created my project, i can commit / push / pull between Terminal and my GitLab project.
Once I try to commit from Xcode 10, still the same fail : “Authentification failed because the credentials were rejected”…

any idea ?

I am having the same problem. We can commit from Xcode, and we can push from command line, but are unable to push/pull from Xcode to Gitlab. We see the same error that Jules has. Yes, we setup SSH correctly, as well as tried using the token, but always have this error. Is there a solution?

I’ll have to raise my hand and join in on this. I too am having the same issue as @magesteve and @jules. I can push from the command line but no luck from Xcode 10. I keep running into authentication issues. It feels like there is a disconnect between the token authentication and the command line SSH authentication. Hopefully, someone will shed some light on what I’m doing wrong :slight_smile:

@ mbender71, If I remember well, after many tries with generating SSH keys from GitLab dashboard, I finally generated a SSH key directly from xCode menu, registrated it and pushed.
Ang magic happened, it has worked.
Don’t ask me why, I also find it strange, but now, it works fine.
Hope it would help you.