How to set up a Gitlab-runner using VirtualBox executor

I’m trying to set up a Gitlab specific runner using VirtualBox as an executor.

I’m using macOS 10.15.5 and here’s what I did:

  • Run gitlab-runner register and use URL and token shown in Settings -> CI/CD
  • Choose virtualbox for executor
  • Run gitlab-runner start

Then I can see the activated Runner in Settings -> CI/CD in my Gitlab project.

But if I commit the .gitlab-ci.yml file, the runner pipeline fails with the following error:

Preparing the "virtualbox" executor
ERROR: Job failed (system failure): exec: "vboxmanage": executable file not found in $PATH

I tried everything to fix this based on Google search, but could not fix this. (especially tried everything from

How can I fix this?


run which vboxmanage on your macOS system. There might be a problem with this not available in the PATH variable.

In case this returns empty, look for VBoxManage or other variants with find / -iname 'vboxmanage' or similar to find out about the exact path. The symlink trick could be needed then.


I have equal problem.
VBoxManage is exists and callable in host terminal.
Manual installation ( sudo curl --output /usr/local/bin/gitlab-runner ) for macos is probably broken or is not well configured.
You try installation with homebrew:

brew install gitlab-runner
brew services start gitlab-runner

But next my problem is in ssh connecting “ERROR: Preparation failed: ssh Dial() error: dial tcp [::1]:52529: connect: connection refused”. SSH connection from host terminal is work.

( )