I am unable to do 2FA of Gitlab using any authenticator app

I am unable to setup my 2FA in Gitlab using any authenticator app. It is saying Invalid pin as an error throw, So I am unable to login to my account.

Thanks in advance
Pradeep G

image

Please try again. There was an active incident causing this problem, which has now been resolved.

Any more details on this issue? Did it impact all Gitlab users or only particular ones setting up a 2FA for a short period of time?

@Overwatcher
All users had been impacted.

For more details, please refer to the production incident issue:

See also:

Hi @gitlab-greg it seems that we are still encountering this issue on one of our users. User is still getting Invalid Pin. What would be the action item on our end for us to fix this issue? Thanks!! I upgraded our instance 2 weeks ago to 14.7.7

If you’re encountering this problem on a self-managed instance, it’s likely atime sync issue between the authentication application and the GitLab instance itself. Please try the troubleshooting steps here: Two-factor authentication | GitLab

hi @gitlab-greg, appreciate your support. thanks. the user have tried it but unfortunately, he still can’t enable again his 2fa. and yes you are correct we are using a self-managed instance. are their any additional steps we can take in order to make the user’s mfa work? thanks a lot!!

I’m experiencing exactly the same issue. Tried to set up 2FA with Google Authenticator and with Authy. None of them worked with “Invalid pin”.

I’m trying to use https://code.videolan.org/

You will need to contact videolan as it is their own Gitlab lnstallation.

1 Like