I can't upgrade omnibus ubuntu 16.04 from 8.9.6 to any of the new 8.10.x

Every time the upgrade stops with errors in this section:

Recipe: gitlab::postgresql
  * execute[enable pg_trgm extension] action run
    [execute] CREATE EXTENSION
              NOTICE:  extension "pg_trgm" already exists, skipping
    - execute /opt/gitlab/bin/gitlab-psql -d gitlabhq_production -c "CREATE EXTENSION IF NOT EXISTS pg_trgm;"
Recipe: gitlab::database_migrations
  * bash[migrate gitlab-rails database] action run
    [execute] rake aborted!
              
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/ffi-1.9.10/lib/ffi/library.rb:263:in `attach'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/ffi-1.9.10/lib/ffi/library.rb:263:in `attach_function'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:13:in `<module:Functions>'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:5:in `<class:Filesystem>'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:4:in `<module:Sys>'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem/functions.rb:3:in `<top (required)>'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem.rb:3:in `require_relative'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/unix/sys/filesystem.rb:3:in `<top (required)>'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/filesystem.rb:11:in `require_relative'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys/filesystem.rb:11:in `<top (required)>'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys-filesystem.rb:1:in `require_relative'
              /opt/gitlab/embedded/service/gem/ruby/2.1.0/gems/sys-filesystem-1.1.6/lib/sys-filesystem.rb:1:in `<top (required)>'
              /opt/gitlab/embedded/service/gitlab-rails/config/application.rb:5:in `<top (required)>'
              /opt/gitlab/embedded/service/gitlab-rails/Rakefile:5:in `require'
              /opt/gitlab/embedded/service/gitlab-rails/Rakefile:5:in `<top (required)>'
              (See full trace by running task with --trace)
              D, [2016-07-28T09:50:07.473700 #7198] DEBUG -- : ** [Raven] Event not sent due to excluded environment: production
    
    ================================================================================
    Error executing action `run` on resource 'bash[migrate gitlab-rails database]'
    ================================================================================
    
    Mixlib::ShellOut::ShellCommandFailed
    ------------------------------------
    Expected process to exit with [0], but received '1'
    ---- Begin output of "bash"  "/tmp/chef-script20160728-6891-u6u8iu" ----
    STDOUT: rake aborted!

Any advice or checks that I can make ?