Installing GitLab runner on aarch64 machine?

Not sure how to install GitLab Runner on Ubuntu server GNU/Linux 4.4.127-mainline-rev1 aarch64.

Tried first setting up the repository, though the install instruction gave me:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gitlab-runner

After that I tried downloading the pre-compiled binaries although there was no matching architecture (the amd64 one gave cannot execute binary file: Exec format error while the arm one Segmentation Fault

Hi there @bbmm_I,

Welcome to the Community!

The GitLab Runner does not currently support ARM64. We do have an ongoing effort to make this available, and you can track our progress in this merge request: Feature ARM64 support.

We are currently working through a couple of roadblocks that should be overcome in the next release, details of which can be found in the MR above. I recommend keeping an eye on that page for any updates and on the matter.

Hi @calebw,

Thanks a lot for your reply!

I’ll follow up then, finger crossed. Any other road I could follow?

Hi @bbmm_I,

No problem at all!

Here are the two relevant issues for the road blocks mentioned in that MR. Besides these, I recommend keeping an eye on our release page as well.