Integration with Jira is giving a 500 error

When I open the JIRA integration page - https://gitlab.com/group/project/-/services/jira/edit (I removed sensitive info)

  • I see a 500 error page with the following text: "
    500
    Whoops, something went wrong on our end.
    Try refreshing the page, or going back and attempting the action again.
    Please contact your GitLab administrator if this problem persists.
    "
    I tried multiple times with no luck.

    We are using gitlab.com
    Thank you,
    D
1 Like

Hi

I have similar error

I’ve updated gitlab from version 12.5.5 to version 12.10.0
And when i trying to edit Settings->Integrations->Jira I’ve caught new error
Could you help my to remove old jira settings?

Completed 200 OK in 26ms (Views: 0.8ms | ActiveRecord: 0.0ms | Elasticsearch: 0.0ms | Allocations: 1123)
Started GET “/root/cont/-/services/jira/edit” for 172.20.7.70 at 2020-04-22 20:47:18 +0000
Processing by Projects::ServicesController#edit as HTML
Parameters: {“namespace_id”=>“root”, “project_id”=>“cont”, “id”=>“jira”}
Completed 500 Internal Server Error in 720ms (ActiveRecord: 64.8ms | Elasticsearch: 0.0ms | Allocations: 222407)

ActionView::Template::Error ():
1: - name = field[:name]
2: - title = field[:title] || name.humanize
3: - value = @service.send(name)
4: - type = field[:type]
5: - placeholder = field[:placeholder]
6: - required = field[:required]

app/models/project_services/data_fields.rb:14:in url' app/models/project_services/jira_service.rb:131:in url’
lib/gitlab/metrics/instrumentation.rb:161:in block in url' lib/gitlab/metrics/method_call.rb:36:in measure’
lib/gitlab/metrics/instrumentation.rb:161:in url' app/views/shared/_field.html.haml:3 app/views/shared/_service_settings.html.haml:62 app/views/shared/_service_settings.html.haml:50:in each’
app/views/shared/_service_settings.html.haml:50
app/views/projects/services/_form.html.haml:14
app/views/projects/services/_form.html.haml:13
app/views/projects/services/edit.html.haml:7
app/controllers/application_controller.rb:125:in render' ee/lib/gitlab/ip_address_state.rb:10:in with’
ee/app/controllers/ee/application_controller.rb:43:in set_current_ip_address' app/controllers/application_controller.rb:479:in set_current_admin’
lib/gitlab/session.rb:11:in with_session' app/controllers/application_controller.rb:470:in set_session_storage’

1 Like

i have the same error, someone please advise how we can remove the old settings. is there a file we edit, a database entry we remove, how do we flush this thing out?

I was able to flush it out by updating the database directly. Needed to update the ‘services’ table to unmark JiraService entries as active, and to delete rows deom the ‘jira_tracker_data’ table.
https://gitlab.com/gitlab-org/gitlab/-/issues/229224

1 Like

Thanks for sharing what worked for you here @mikeyc7m I’ve marked your comment as a solution.